Frequently Asked Questions

Are your plugins compatible with macOS Mojave and/or Catalina?
Last Updated 2 years ago

Our plugins support a wide range of Mac OS X / macOS versions. We do not specifically test against particular OS versions, but our software is digitally signed (Gatekeeper signature) and scanned by Apple's servers (Gatekeeper notarized), so you should not encounter any issues installing on those versions.

Please Wait!

Please wait... it will take a second!